HTTPSページでエラーが出る場合はブラウザがTLS 1.2に対応しているか確認する

暗号化通信の脆弱性対策で、暗号化方式TLS1.2への移行が進んでいます。
スターバックスの HTTPS使用ページでも、9/11以降に TLS 1.2に未対応ブラウザでの表示ができなくなったようです。

スターバックス、公式サイトのHTTPS接続ページで「TLS 1.0/1.1」を無効化、「TLS 1.2」のみの対応へ -INTERNET Watch

Android標準ブラウザで実際にアクセスしてみると、下の画像のように「接続エラー:安全な接続を確立できませんでした」と出てアクセス出来ません。

画像



Android 4.4以前のスマートフォンで対象ページが閲覧できなくなるとのことですが、Android 4.2 でも GoogleChrome を使えば接続できました。
最新の GoogleChrome ではTLS 1.2に対応しているためです。


お使いのブラウザが TLS 1.2 に対応しているかは、次のページで確認できます。
アクセス後、画面右側の [Test your browser] をクリックします。

https://www.ssllabs.com/


Protocol Support の個所に緑色で「Your user agent has good protocol support.」と出ればOKです。
また、Logjam Vulnerability 等の個所で「Your user agent is not vulnerable.」となっていることも確認して下さい。

画像



下図のように赤字で表示された場合は、問題ありです。
最新のブラウザを使用しましょう。

画像





ブログ気持玉

クリックして気持ちを伝えよう!

ログインしてクリックすれば、自分のブログへのリンクが付きます。

→ログインへ

なるほど(納得、参考になった、ヘー)
驚いた
面白い
ナイス
ガッツ(がんばれ!)
かわいい

気持玉数 : 1

なるほど(納得、参考になった、ヘー)

この記事へのコメント

この記事へのトラックバック