パソコン鳥のブログ

アクセスカウンタ

zoom RSS rpmの強制インストール

<<   作成日時 : 2017/04/07 19:40   >>

トラックバック 0 / コメント 0

rpmの強制インストールです。

--force オプションを付けます。


rpm -ivh --force rpmパッケージファイル名



下記のように、「エラー: 依存性の欠如」と出た場合は、更に --nodeps オプションを付けます。


# rpm -ivh --force postgrey-1.34-1.el6.rf.noarch.rpm
警告: postgrey-1.34-1.el6.rf.noarch.rpm: ヘッダ V3 DSA/SHA1 Signature, key ID 6b8d79e6: NOKEY
エラー: 依存性の欠如:
perl(Parse::Syslog) は postgrey-1.34-1.el6.rf.noarch に必要とされています



下記のようにします。


rpm -ivh --force --nodeps rpmパッケージファイル名



これで rpmパッケージを強制的にインストールできます。


参考


RPMパッケージの強制インストール - weblog of key_amb
rpm 操作ガイド

テーマ

関連テーマ 一覧


月別リンク

トラックバック(0件)

タイトル (本文) ブログ名/日時

トラックバック用URL help


自分のブログにトラックバック記事作成(会員用) help

タイトル
本 文

コメント(0件)

内 容 ニックネーム/日時

コメントする help

ニックネーム
本 文
rpmの強制インストール パソコン鳥のブログ/BIGLOBEウェブリブログ
文字サイズ:       閉じる