パソコン鳥のブログ

アクセスカウンタ

zoom RSS Ubuntu14.04 , apache2.4 で cgiが実行されない

<<   作成日時 : 2015/03/30 19:00   >>

ブログ気持玉 0 / トラックバック 0 / コメント 0

Ubuntu14.04、apache2.4 で cgiが実行されない場合の確認事項です。

/usr/lib/cgi-bin 下に cgiファイルがあるか?
デフォルトでは、cgidファイルは /usr/lib/cgi-bin 下に置く必要があります。
また拡張子は cgi でなくてはいかません。


cgi ファイルに実行権限があるか?
実行権限が無い場合は、
chmod +x cgiファイル名
を実行して実行権を付加します。


cgi 実行が有効化されているか?
ls -la /etc/apache2/mods-enabled/
実行で、次のシンボリックリンクがあるか確認します。


cgid.conf -> ../mods-available/cgid.conf
cgid.load -> ../mods-available/cgid.load


無い場合、a2enmod cgi 後に service apache2 restart します。

これで、シンボリックリンクが作成され、cgiが有効になります。




テーマ

関連テーマ 一覧


月別リンク

ブログ気持玉

クリックして気持ちを伝えよう!
ログインしてクリックすれば、自分のブログへのリンクが付きます。
→ログインへ

トラックバック(0件)

タイトル (本文) ブログ名/日時

トラックバック用URL help


自分のブログにトラックバック記事作成(会員用) help

タイトル
本 文

コメント(0件)

内 容 ニックネーム/日時

コメントする help

ニックネーム
本 文
Ubuntu14.04 , apache2.4 で cgiが実行されない パソコン鳥のブログ/BIGLOBEウェブリブログ
文字サイズ:       閉じる